If you are using an old version of the game, you can download a version of the mod that is compatible with the game version you are using from below.

[ads_shortcode]

Only stable releases of the mod are available on this page. Other versions are not included.

Versions & Download Links

Version 7.1 (ETS 2) & Version 3.0 (ATS)

Supported Game Version(s): 1.39

Required configurations:
g_suspension_stiffness 0.85
g_cabin_suspension_stiffness 1.0
g_truck_stability 1.0
g_trailer_stability 1.0

Version 7.0 (ETS 2) & Version 2.0 (ATS)

Supported Game Version(s): 1.38

Version 6.1

Supported Game Version(s): 1.37

Version 6.0

Supported Game Version(s): 1.35, 1.36

Version 5.8

Supported Game Version(s): 1.33, 1.34, 1.35

[ads_shortcode]

Terms of Use of Our Mods

Please read the terms below before using our mods. By downloading and using our mods, you agree these terms.
- Do not copy any data from mods.
- Do not edit/change mod files unless necessary.
- If you edit/change mod files, do not share them with anyone.
- Do not upload mod files to websites.
If you want to share the mod on the web, you must comply with our mod sharing terms. View terms